Jump to content
filo-sergey

FSINN. Вопросы и ответы

Recommended Posts

Думаю этому вопросу здесь место: при загрузке ранее сохраненных полетов сим вылетает с ошибкой модуля fscopilot.dll. Ни кто не сталкивался с таким, чем можно пролечить?

Share this post


Link to post
Share on other sites

Думаю этому вопросу здесь место: при загрузке ранее сохраненных полетов сим вылетает с ошибкой модуля fscopilot.dll. Ни кто не сталкивался с таким, чем можно пролечить?

Тут что-то с UIAUTOMATION.DLL

Вернее, надо пофиксить.

Погуглите - должно быть, обсуждалось на Vatsim или avsim не раз. Не Вы первый, как говорится.  :)

Только обратите внимание на версию винды в ответах. 

Edited by Uncle_Sam

Share this post


Link to post
Share on other sites

Помогите! Не давно получил вот такую беду  :sad:

 

 

Имя события проблемы:    BEX
  Имя приложения:    fsx.exe
  Версия приложения:    10.0.61472.0
  Отметка времени приложения:    475e17d3
  Имя модуля с ошибкой:    StackHash_ec08
  Версия модуля с ошибкой:    0.0.0.0
  Отметка времени модуля с ошибкой:    00000000
  Смещение исключения:    PCH_91_FROM_FSCopilot+0x00064695
  Код исключения:    c0000005
  Данные исключения:    00000008
  Версия ОС:    6.3.9600.2.0.0.768.101
  Код языка:    1049
  Дополнительные сведения 1:    ec08
  Дополнительные сведения 2:    ec086a8c9ad58566a5bfa1f073f3bf56
  Дополнительные сведения 3:    d108
  Дополнительные сведения 4:    d108f4a6530fdc815e862fb4f647e90

 

 

Это, наверняка, при выходе из FSX.  Так?

Share this post


Link to post
Share on other sites

Ребят подскажите: установил Фсин, при попытке открыть его панель - вешает намертво сим. На ноуте все нормально. Удалял,ставил по новой,без толку! Вешает и все! Другие менюшки работают исправно. ЧТо может быть? Сим 10,разгон, при первой установке панель запустилась, коннект с ватсимом состоялся. На следующий день просто вешает и все..

Share this post


Link to post
Share on other sites

Ребят подскажите: установил Фсин, при попытке открыть его панель - вешает намертво сим. На ноуте все нормально. Удалял,ставил по новой,без толку! Вешает и все! Другие менюшки работают исправно. ЧТо может быть? Сим 10,разгон, при первой установке панель запустилась, коннект с ватсимом состоялся. На следующий день просто вешает и все..

запускайте фсинн загрузившись в дефолтном крафте. потом, просто меняете самолет и все...

Share this post


Link to post
Share on other sites

запускайте фсинн загрузившись в дефолтном крафте. потом, просто меняете самолет и все...

спасибо! Заработало! Всегда что-ли нужно грузить дефолтный крафт,,,

Share this post


Link to post
Share on other sites

К сожалению всегда, для нормальной работы... У кого-то нормально, у кого-то с проблемами. У меня такие проблемы часто, вот и загружаюсь, от греха подальше, с дефолтным самолетом.

Edited by maxam

Share this post


Link to post
Share on other sites
 

Старый дедовский способ заработал. Гружу сначала дефолтный полет, а потом уже сохранение и все работает. По dll уже давно пофиксил, так что сомневаюсь что в ней было дело.

Edited by elefantooo

Share this post


Link to post
Share on other sites

Напомните пожалуйста,как должен выглядеть файл "игнор". Я сделал файл FSinn.cfg ignore=1,но ФСИН все равно грузит все крафты

Share this post


Link to post
Share on other sites

И снова здравствуйте!Опять полночи убил на борьбу с фсинном. Ситуация такая,повторилась во второй раз. Я вытаскиваю наушники(спаренные с микро) из системника,через какое то время опять вставляю,захожу в ватсим и опачки-не слышу ни диспов ни сам не могу ничего сказать.Первый раз проверил настройки,и светофор-слетели настройки,поправил-все заработало. Сегодня аналогичная же ситуация,только с одним отличием,я диспетчера слышу,частота есть,но меня не слышат..В светофорчики оборудование-появилось..Настройки поправил все равно толку ноль. Что еще и где конкретно искать проблему?

Share this post


Link to post
Share on other sites

Ребят,кто сталкивался,подскажите пожалуйста.

Share this post


Link to post
Share on other sites

Доброго времени Господа.

Помогите пожалуйста в одном вопросе. Без вас никак.

Дело вот в чем. FSinn потерял связь с самолетом. При загрузке на аэродроме появляется светофорчик, потом запускаю Control Panel, грузится трафик, коннектится с VATSIM, отображаются активные частоты УВД, короче всё как обычно, без замечаний. Однако при попытках изменения частоты на радиостанциях самолёта, а также при изменении кода ответчика на радиопанели самолёта изменений во FSinn не происходит. Открываем окошко АТС, смотрим на список диспетчеров. В нормальных условиях при выборе частоты определенного диспетчера таблица закрывалась и в окне таблицы оставались только данные соответствующего диспетчера, а в случаях с АТИС появлялась текстовая информация метеоусловий. Сейчас - ничего не происходит. Смотрим servinfo. Ответчик давно уже 2200, а на servinfo 1200 (как по умолчанию). Что интересно, в сети VATSIM самолет есть, т.е. соединение произошло, его видно на servinfo и диспетчер его тоже видит.
Скажу сразу, что переустанавливал FSinn и Copilot 4 раза, реестр чистил и программно и через regedit, хотя почистил наверно не всё, т.к. во вновь установленном FSinn отобразилась история позывных, которые я вводил раньше. Ничего не изменилось. В итоге снес и FSUIPC и Ездок (почему-то тоже потерял связь с бортом, короче глюканул) и FSinn и Copilot. Установил всё заново, в правильном порядке, настроил всё согласно инструкций, дважды проверил. В итоге всё кроме FSinn работает 5 by 5, а связи самолёта как не было, так и нет. Всё время загружался на PMDG. Попробывал загрузиться на дефолте. Вроде с переменным успехом смог изменить частоту радиостанции. Слышу диспа, а он меня нет соответственно. Потом опять глюк какой-то и радиостанция самолета перестала оказывать влияние на FSinn.

И еще одна проблема. В настройках FSinn (через светофор) есть функция установки тангенты радиостанции (задается кнопка переговорного устройства "нажал-сказал"). Так вот я её изменить не могу. Жму кнопку "SET", говорит мне нажать удобную для меня кнопку, нажимаю, и такое впечатление, что клавиатура отсоединена от компа. Короче, никаких реакций. При этом в самом симуляторе все кнопки клавиатуры работают, но FSinn почему-то на них не реагирует. И на светофоре светится красным "FS with FSCopilot isn't connected. Start FS or check condiguration."

https://www.facebook.com/photo.php?fbid=685514988161725&set=p.685514988161725&type=1&theater
 

Посоветуйте пожалуйста, что делать? Понимаю что много читать, но постарался записать всё.
А-то уже несколько дней никуда не могу полететь. Может кто-то сталкивался с подобным.
Заранее благодарен.

Share this post


Link to post
Share on other sites

Дело вот в чем. FSinn потерял связь с самолетом.

 

Посоветуйте пожалуйста, что делать? Понимаю что много читать, но постарался записать всё.

 

 

Тут надо вспомнить, что же было сделано с симом, после чего FSInn начал себя так вести. Что-то меняли в системе? Может затронули "тонкую настройку" FSInn - правильно выставленные права на запуск (от администратора)? Если что - в чате FSInn-а можно командами менять и чатсоту СОМ-приемников и ответчик. Если там менять - отражаются изменения в симе на радиопанелях? Но скорее всего где-то трогали настройки запуска. И сим и FSInn должны запускаться от админа, и все нужные модули FSInn тоже должны быть от админа.

  • Upvote 1

Share this post


Link to post
Share on other sites

И права от админа установлены на все нужные файлы (согласно инструкции FSinn.pdf), и внесено всё в исключения брендмауера и антивируса (НОД). И брендмауер вообще отключил.

А случилось так. Полетел я в один порт (LUKK), находящийся недалеко от моего порта приписки (UKBB). Приземлился, срулил, встал на стоянку, попрощался, ..., вышел из FSinn, завершил полёт, закрыл симулятор. Короче всё как обычно. Кстати у меня FSX. На следущий день решил назад вернуться, и всё! Летел оффлайн. Ничего не менял, ничего не устанавливал сверху. Поэтому и пишу сюда. Не могу понять, в чем дело. Похоже на какой-то глюк реестра.

Share this post


Link to post
Share on other sites

Напомните пожалуйста,как должен выглядеть файл "игнор". Я сделал файл FSinn.cfg ignore=1,но ФСИН все равно грузит все крафты

[FSINN]
IGNORE=1
 Вот так должно быть написано в файле FSInn cfg. Затем закиньте этот файл в корень того самолета который вам не нужен.

Share this post


Link to post
Share on other sites

Парни, кто сталкивался с подобным.

 

Перестал слышать диспов. При том меня они прекрасно слышат, но я - ни слова. Случилось это внезапно,  переустановка FSInn не помогла. Эксперименты с антивирусом тоже, хотя он и никогда не блокировал. Грешу на некорректное удаление FS Flight Keeper. 

Share this post


Link to post
Share on other sites

У меня было похожее, дело было в настройках звука в компе.

Share this post


Link to post
Share on other sites

У меня было похожее, дело было в настройках звука в компе.

 

А что именно? У меня есть колонки, которые подключены через стандартный джек. А есть USB наушники. Но настроено все правильно вроде...

Share this post


Link to post
Share on other sites

А что именно? У меня есть колонки, которые подключены через стандартный джек. А есть USB наушники. Но настроено все правильно вроде...

Какой у Вас интернет провайдер? Если Укртелеком, то я знаю в чем дело. При Укртелекоме иногда слышно диспетчеров кусками. Например, слышишь половину предложения, а вторую вообще не слышно. Здесь помогает такая программа как HotSpot. После её включения Вы как будь-то соединяетесь с другой страны, это можно увидеть в Тимспике, например, по флажку государства. Включать и выключать программу нужно до тех пор, пока она не законнектит Вас из любой страны кроме США и Швейцарии. У меня когда эти флажки появляются, связь тоже глючная. Но может у Вас и другой вариант, может какие порты не открываются, такое тоже бывает.

Share this post


Link to post
Share on other sites

В фсине есть настройки звука, там надо выбрать формат воспроизведения в соответствии вашей звуковой карты.

Share this post


Link to post
Share on other sites

to hrjushkin

 

Удалил опять FSinn & Copilot. Скачал новые инстоляторы.

Снова переустановил и проверил свой FSinn. На светофоре как и раньше отмечено красным глазом  "FS with FScopilot isn't connected. Start FS or check configuration."

C VATSIM коннектится нормально, но как и раньше с радиостанции самолета частоты во FSinn не меняются, а вот с радиопанели FSinn частоты менять можно, при этом они меняются и на радиостанциях самолёта.

Как и раньше не могу установить кнопку на тангенту (нажми-говори). Жму на "SET" и такое впечатление, что клавиатура вообще отсоединена от компа.

Все файлы перечисленные в инструкции (http://vacc-ua.aero/information/pilots/training/vatsim/FSInn.pdf) настроены для запуска от администратора.

В общем по инструкции всё, а толку нет. И главное, что когда я устанавливал FSinn & Copilot раньше на этот же комп, я никогда не проверял и не настраивал всё так дотошно как сейчас. Всё работало.

Помогите пожалуйста.

Просто не знаю что уже делать.

Не уже ли придется всё, включая винду переставлять? Боюсь даже думать.

Более подробно описано несколькими сообщениями выше.

Share this post


Link to post
Share on other sites

Тут надо вспомнить, что же было сделано с симом, после чего FSInn начал себя так вести. Что-то меняли в системе? Может затронули "тонкую настройку" FSInn - правильно выставленные права на запуск (от администратора)? Если что - в чате FSInn-а можно командами менять и чатсоту СОМ-приемников и ответчик. Если там менять - отражаются изменения в симе на радиопанелях? Но скорее всего где-то трогали настройки запуска. И сим и FSInn должны запускаться от админа, и все нужные модули FSInn тоже должны быть от админа.

Удалил опять FSinn & Copilot. Вычистил от него реестр всем, чем только можно было это сделать. Скачал другие инстоляторы на VAC UA, чтобы уже точно всё по новому было.

Снова переустановил и проверил свой FSinn. На светофоре как и раньше отмечено красным глазом  "FS with FScopilot isn't connected. Start FS or check configuration."

C VATSIM коннектится нормально, но как и раньше с радиостанции самолета частоты во FSinn не меняются, а вот с радиопанели FSinn частоты менять можно, при этом они меняются и на радиостанциях самолёта.

Как и раньше не могу установить кнопку на тангенту (нажми-говори). Жму на "SET" и такое впечатление, что клавиатура вообще отсоединена от компа.

Все файлы перечисленные в инструкции (http://vacc-ua.aero/...atsim/FSInn.pdf) настроены для запуска от администратора.

В общем по инструкции всё, а толку нет. И главное, что когда я устанавливал FSinn & Copilot раньше на этот же комп, я никогда не проверял и не настраивал всё так дотошно как сейчас. Всё работало.

Помогите пожалуйста.

Просто не знаю что уже делать.

Edited by GarikS

Share this post


Link to post
Share on other sites

Да и еще, наверно это тоже очень важно, но единственное, что я не смог сделать согласно инструкции так это поставить галочку "запускать от администратора" на приложение dpnsvr.exe (DirectPlay8). Оно находится в C:\Windows\System32\drivers\etc (WIN 7). Когда я пытался это сделать то обнаружил, что в свойствах этого файла все квадратики неактивны (серым цветом). Установить галочку я не могу, хотя и по инструкции и нужно. Сейчас там пустое окошко без галочки.

Share this post


Link to post
Share on other sites

Всем привет.

Тут вот какое дело. Перед уходом в армию летал в ватсиме нормально, без всяких проблем.3 месяца назад вернулся, снес сим полностью со всеми прилегающими прогами к нему и поставил заново, подключаюсь к ватсиму - а он мне ошибку выдает (см. картинку). на 3-х серверах ошибку выдает, к остальным 4-м просто не подключает...

Ребята, если честно, все перерыл, ничего не нашел...Помогите. Хэлп ми....

 

post-53117-0-08268200-1396165608_thumb.jpg

Share this post


Link to post
Share on other sites

Всем привет.

Тут вот какое дело. Перед уходом в армию летал в ватсиме нормально, без всяких проблем.3 месяца назад вернулся, снес сим полностью со всеми прилегающими прогами к нему и поставил заново, подключаюсь к ватсиму - а он мне ошибку выдает (см. картинку). на 3-х серверах ошибку выдает, к остальным 4-м просто не подключает...

Ребята, если честно, все перерыл, ничего не нашел...Помогите. Хэлп ми....

Аккаунт не заблокирован?

Внимательно читайте тут:

http://www.avsim.su/forum/topic/119090-%D0%BF%D1%80%D0%BE%D0%B1%D0%BB%D0%B5%D0%BC%D1%8B-%D1%81-%D1%83%D1%87%D0%B5%D1%82%D0%BD%D0%BE%D0%B9-%D0%B7%D0%B0%D0%BF%D0%B8%D1%81%D1%8C%D1%8E-%D0%B2%D0%B0%D1%82%D1%81%D0%B8%D0%BC/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...