Jump to content

Казачок

Members
  • Content Count

    1087
  • Joined

  • Last visited

  • Days Won

    4

Everything posted by Казачок

  1. Да, конечно. [Fuel] fuel_type = 2 number_of_tank_selectors= 2 electric_pump = 1 // // 6.7 lbs/gal; -> 3.04liters/Gal -> (1Gal=3.786liters) -> Ro~0.8 // LeftMain = -7.3, -14.0, -0.6, 2055.0, 66.0 RightMain= -7.3, 14.0, -0.6, 2055.0, 66.0 //aav //Center1 = -7.3, 0.0, 0.0, 539.6, 3.0 //Max fuel wgt 27,025 lb - Ref 1 //LeftMain = -7.3, -14.0, -0.6, 1747.0, 3.0 //RightMain= -7.3, 14.0, -0.6, 1747.0, 3.0 И сумму-то правильно показывает...
  2. Большое спасибо, Александр! Интересно, что такой вариант я записывал. Только при нём прибор всё равно упорно показывает 0. Ни как не пойму - в чём дело?
  3. Здравствуйте! Прошу помощи! Простейший прибор - цифровой указатель уровня топлива в левом баке. Показывать должен в килограммах. Выдернул из похожего прибора строку, указывающую общее количество топлива в левом и правом баке: <Text X="73" Y="17" Bright="Yes" Length="6" Font="Arial" Color="LightGreen" Adjust="Center" VerticalAdjust="Center" Multiline="No"> <String>%((A:Fuel total quantity weight, kilogram)) %!5d!</String> </Text> Работает - Показывает сумму. Пытаюсь переписать строку только под левый бак. Например так: <Text X="73" Y="17" Bright="Yes" Length="6" Font="Arial" Color="LightGreen" Adjust="Center" VerticalAdjust="Center" Multiline="No"> <String>%((A:Fuel tank left main quantity weight, kilogram)) %!5d!</String> </Text> - Ничего не выходит. Указатель упорно показывает 0. Как мне правильно записать строку, что бы указатель показывал топливо в килограммах в левом (правом) баке?
  4. Здравствуйте! Вот предположим, должно запустится событие (например, загореться контрольная лампа) при включении (L:BSKD_MD1, enum) или (L:BSKD_MD2, enum). Я записываю выражение <Value>(L:BSKD_MD1, enum) || (L:BSKD_MD2, enum)</Value>. Но в таком виде контрольная лампа загорается только при включении (L:BSKD_MD2, enum). Как мне правильно поставить знак "ИЛИ", что бы событие запускалось при L:1 или L:2 ?
  5. Да обыкновенно реализован )) - "Механизм" свинчен с дефолтного B747-400 (MFS2004). Полагаю тут G-переменные замешаны?
  6. Вот ещё одно.... ХАЭ-85 попытался изобразить. получается вот что: Один и тот же прибор, но записанный в разные окна 2D панели, ведет себя не синхронно. Причём как-то на половину... Текущее время показывает нормально. Секундомер управляется нормально. А вот время полёта одинаково отображать не хочет. В одном окне нажимаю кнопку "Старт" - Время пошло. А в другом окне этот же самый прибор стоит на месте, и кнопка не нажата. В чём дело?
  7. Огромное Спасибо! Это действительно помогло! Теперь всё, как нужно!
  8. Здравствуйте! Столкнулся с проблемой... Есть строка в приборе, отвечающая за шрифт (цифры в часах): <Text X="67" Y="27" Bright="Yes" Length="5" Font="Quartz" Fixed="Yes" FontWeight="800" Color="#E0E0E0" HilightColor="Yellow"> С приведённой строкой цифры на табло белые. Мне нужно, что бы они были зелёного цвета. За цвет шрифта, как понимаю, отвечает запись Color="#E0E0E0"? Так вот... Взял я из другого прибора (с зелёным шрифтом) строку Color="#FFFFFF" , но ничего не поменялось - В моём приборе шрифт по прежнему белый. Как мне его (цвет шрифта) изменить? И, если возможно, расскажите пожалуйста, что означают остальные записи строки (Length="5, FontWeight="800", HilightColor="Yellow")?
  9. Да. Всё так. Только хорошо, когда на XML свободно пишешь. А я только со "словарём" :-) (В других приборах подглядишь и пытаешься что-то подобное наваять). И без Ваших подсказок вообще бы туго пришлось ))).
  10. Огромное Спасибо! Это именно то, что я искал. Мне действительно нужно создать иллюзию наличия двух АКБ (топливных насосов на один двигатель). Логическую схему я тоже стараюсь себе представить перед написанием какого либо прибора, но получаются только самые примитивные.
  11. Здравствуйте! Есть вопрос: Можно ли написать два тумблера, которые управляли бы одним событием, независимо друг от друга? Например: Аккумулятор (или топливный насос двигателя 1) включается и выключается тумблером №1 или №2, или сразу №1 и №2. Я пробовал сделать тумблеры через L переменные, но они у меня включаются - выключаются с оглядкой друг на друга.
  12. Спасибо Вам! Две одинаковые переменные - Это просто ошибка. Там (L:VU2_switch,bool) ещё должно быть. Вообще я иногда, наверное, полную бредятину пишу. Я не программист, Просто люблю модели самолётов немного улучшать, по возможности. Рисовать у меня чуть лучше выходит (Текстуры, иногда панели). А XML... Просто выискиваю в разных панелях приборы, похожие на те, что нужны мне. Пытаюсь воспроизвести, часто просто пробуя разные варианты практически вслепую. Мучительно долго потом пытаюсь запустить то, что нагородил. Не знаю, как язык освоить, что бы хоть что-то писать осознано. Часто уповаю только на Вашу помощь в этой вот теме. Вот такие вот "муки творчества". Ну ладно... Что-то я тут разнылся )). Пойду поищу чего нибудь с таймером. Ещё раз спасибо за помощь!
  13. Всех приветствую! Коллеги! Выручите пожалуйста (в который раз)... Есть пара вопросов (но это только пока )))... Как записать значение "или" вот в таком условии: <Value>(L:VU1_switch,bool) ИЛИ (L:VU1_switch,bool) if{(L:Obogrev_AKB1-2_switch,bool) ! } </Value> И ещё... Нужно, что бы после нажатия произвольной кнопки загорелась и через две секунды погасла лампа вот в таком коде: <Element> <Select> <Value>(L:VU1_switch,bool) 1 == (P:Local Time,seconds) ?????? </Value> <Case Value="0"> <Image Name="Lampa_2_0.bmp"/> </Case> <Case Value="1"> <Image Name="Lampa_2_OTKAZ.bmp" Bright="Yes"/> </Case> </Select> </Element> Опять тупо не знаю, какие знаки нужно писать.
  14. Да! Всё верно... Благодарю за помощь! Из лёгких сценариев Нижегородской области афкад XUDK я удалил, а оказывается был ещё один - В сцене UWGG. Теперь всё на местах и работает. Моя доволен . Ещё раз огромное спасибо! Кстати, кому интересно (или есть такая же проблема), вот эти две текстуры вызывали замыливание текстур вокруг Богородска: За что они отвечают, я так и не понял - После их удаления ни каких изменений (кроме, конечно, отсутствия замыливания) не заметил.
  15. Приветствую, уважаемые коллеги! Возникла вот у меня проблемка со сценарием - Уж и не знаю в какую сторону копать. Помогите пожалуйста разобраться. Суть вот в чём: Есть сценарий аэродрома Богородск (тот, что в Нижегородской области). Долгое время им не пользовался, так как при полётах на этом аэродроме и в окрестностях возникало сильное замыливание текстур в симуляторе. Я решил найти всё таки корень проблемы. Покопавшись, выловил две текстурки, которые устраивали это безобразие. И вот вроде бы "ура", но появилась другая проблема: Пропала полоса и рулёжки. Раньше они были. Выглядело всё так: Теперь не пойму - Объекты все на местах а полосы с рулёжками нет Несколько раз сносил и ставил заново сценарий - Не помогает. Нет полосы. Сразу оговорюсь - Отловленные, гадкие текстуры к ВПП отношения не имеют ни какого. Очень надеюсь на помощь специалистов в этой области. Где искать ошибку? Буду очень признателен за любую подсказку. Ведь этот аэродром для меня практически домашний . P.S. Симулятор - MFS2004.
  16. Для обоих П0-750 должен быть включён (тумблер в самом центре, прямо под надписью "переменны ток 115в"). Странно... Вот он в панели бортинженера: gauge18=An24_XML!PO-750_switch, 208,158,16,48 Если в составе панели ничего не менялось, то должно всё работать. Не понимаю...
  17. Приветствую, Алексей! Сейчас попытаемся разобраться. Что бы работали все авиагоризонты, нужно что бы все тумблеры на импровизированной панели бортинженера были включены. Вот так (проверь): А высотомер у второго пилота, это ты наверное УВИД имеешь в виду, что в ВК установлен? Он тублером включается вот здесь: Надеюсь всё заработает .
  18. Если не путаю, то вот здесь я его из панели не удалял: https://www.avsim.su/f/fs2004-originalnie-samoleti-40/transportniy-samolyot-an-26-59872.html
  19. https://www.avsim.su/f/fs2004-originalnie-samoleti-40/an-24-rv-noviy-paket-15998.html Не эта случаем?
  20. Большое спасибо за помощь! Самое оно, наверное... Но вот какая проблема: Трафик у меня свой, сборный. Вчера установил в него модель Ан-2 RWAI (model=Serp) - Всё работает. Все самолёты на своих местах. Летают, стоят на стоянках... И всё бы хорошо, но большинство текстур к этой модели нарисованы для варианта с обычным винтом. Прописал я в aircraft.cfg model=Wheel, что скачал по Вашей ссылке и чудеса - Практически все Ан-2 из трафика пропали. Не то, что бы их совсем нет... Один самолёт мне всё таки обнаружить удалось - Стоит себе на стоянке, с прямым винтом (как и задумывалось). То есть модель-то всё таки прописалась. Но это единственный случай - Других Ан-2 в трафике на своих местах нет. И всё меняет лишь измене строки в aircraft.cfg с model=Serp, на model=Wheel. model=Serp - Трафик работает нормально. Пишем model=Wheel - И практически все Ан-2 исчезают. Может кто подскажет, в чём ошибка? Если не разберусь, придётся во всех текстурах винт гнуть - Очень не хочется.
×
×
  • Create New...